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Introduction 
As defined by Wikipedia, open-source software is computer software for which the source code 
is made available and permits users to use, change, and improve the software and to redistribute 
it in modified or unmodified form. It is very often developed in a public, collaborative manner.  
One report by Standish Group (http://standishgroup.com/) estimates that the adoption of open-
source software has saved consumers about $60 billion per year. 
 
While open source software has no licensing fee to download, use, modify, and distribute, it 
doesn’t necessarily mean it is “free.”  As you begin to investigate the potential for using open 
source software in your organization, consider the following: 
 
♦ Who will host and/or support the applications?  
♦ Who will install and maintain the applications? 
♦ How will users be trained on the new applications? 
♦ How will collaboration be impacted by the use of non-proprietary applications?  
 
When calculating the cost of using software, compare the cost of using an open-source 
application versus proprietary, off-the-shelf applications by considering the total cost of 
ownership by using a matrix as shown below: 
 

Consideration Option 1 Option 2 
Application Name:   
Software vendor fee:   
License fee:   
Annual maintenance fee:   
Administration and support (upgrades and patches) costs:   
Training costs:   
Labor cost for installing:   
Programming costs for customizations:   
System integration fees:   
Hardware costs:   
Total Ownership Costs:   
(For a more extensive criteria comparison and calculation, refer to the report “Free and Open Source Software: Overview and Preliminary 
Guidelines for the Government of Canada” available at: http://www.tbs-sct.gc.ca/fap-paf/oss-ll/foss-llo/foss-llo-eng.pdf.) 
 
After determining an application is an appropriate fit for your project’s needs, download and 
install the desired application.  The following pages will help guide you through the steps of 
using several applications to produce a SCORM-based E-Learning module: 
 

Task Application (Page #) Application (Page #) 
Multimedia Audacity Audio Recording (p. 4) Wink Screen Recording (p. 10) 
Image Editing GIMP (p. 6) Paint.NET (p. 8) 
Course Authoring eXe (p. 13) MyUdutu (p. 16) 
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Audacity Audio Recording 
Audacity is a free, easy-to-use audio editor and recorder.  You can use Audacity to: 
 
♦ Record live audio 
♦ Convert tapes and records into digital recordings or CDs 
♦ Edit sound files (e.g., MP3, WAV) 
♦ Cut, copy, splice or mix sounds together 
♦ Change the speed or pitch of a recording 
 
The following procedure shows you how to record and edit a typical voice narration audio file 
using Audacity: 
 
Procedure  

1.  Plug your microphone in and click the Record button  to begin recording.  

2.  Click the Stop button  to stop the recording.  

3.  Click the Rewind button  to return to the beginning of the file.  
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4.  Select section to delete and click the Cut button .  
5.  Click the Generate > Silence... menu item. 

 

6.  Type the number of seconds and the click the Generate Silence button .  

7.  Click the File > Export As MP3... menu item.  
8.  Type the file name and then click the Save button .  

 

9.  Type a title in the Title field and then click the OK button .  

10. Click File > Exit to close Audacity. 
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GNU Image Manipulation Program Image Editing 
The GNU Image Manipulation Program (GIMP) is a multi-platform photo manipulation tool.  
You can use this software to: 
 
♦ Retouch photos 
♦ Compose new images 
♦ Modify existing images 
 
The following procedure shows you how to resize an existing image with GIMP: 
 

Procedure 

 

1.  Click the File > Open menu item.  
2.  Select the desired file and click the Open button .  

3.  To view the image at full-size, click the View Magnification drop-down.  
4.  Click the 100% list item.  
5.  To begin modifying the image, click the Image > Scale Image menu item.  
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6.  Enter the desired sizes and click the Scale button .  

7.  Click the Crop tool from toolbar .  

8. Select the area to be cropped and click within the cropping area. 

9.  Click the File > Save a Copy menu item.  

 

10. Type the file name, ensure the correct file type is selected, and then click the Save button .

 

11. Click the Save button .  
12. Click the window’s Close button .  
13. Click the Don't Save button  to preserve the original file.  
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Paint.NET Image Editing 
Paint.NET is free image and photo editing software for Windows. It  features an intuitive and 
innovative user interface with support for:  
 
♦ Layers 
♦ Unlimited undo 
♦ Special effects 
♦ Useful and powerful tools 
 
The following procedure shows you how to resize an existing image with Paint.NET: 
 
Procedure 

1.  Click the File > Open... menu item.  
2.  Select the desired file and click the Open button .  

 

3.  To view the image at full-size, click the Magnification drop-down .  
4.  Click the 100% list item.  
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5.  To begin making modifications to the image, click the Image > Resize... menu item.  

 

6.  Click the By absolute size: radio button .  
7.  Click the Height: text box and type the new height .  
8.  Click the OK button .  
9.  Use the Selection tool to select the desired area and click the Image > Crop to Selection menu 

item. 
10. Click the File > Save As... menu item.  
11. Name the new file and click the Save button .  
12. Click the OK button .  
13. Click the File > Close menu item.  
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Wink Screen Recording 
Wink is a Tutorial and Presentation creation software, primarily aimed at creating tutorials on 
how to use software applications.  Using Wink you can:  
 
♦ Capture screenshots 
♦ Add explanations boxes, buttons, and titles 
♦ Generate a Flash-based demonstration of the steps and actions 
 

Note:  Wink is a free software application offered by Debugmode.  It is copyrighted by 
Satish Kumar. S., and as such, is not considered an open-source application.  However, 

because of the usefulness and no-fee nature of this tool, Wink is included in this workbook. 
 
The following procedure shows you how to create a software demonstration recording using 
Wink: 
 

Procedure 

 

1.  Click the New Project button .  
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2.  Click the OK button .  
3.  Click the Minimize To Tray button .  
4.  Complete the steps and actions you wish to demonstrate and capture in the recording.  
5.  Right-click the Wink Capture button in the Windows Taskbar. 

6.  Click the Stop Timed Capture menu item.  
7.  Right-click the Wink Capture button . 

8.  Click the Finish Capture menu item.  

 

9.  Click the Render button .  
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10. Type the Output File Name and click the OK button .  
11. To view the recorded demonstration, click the View Rendered Output button .  
12. Click the Close button on the output window .  
13. Click the Save Project button . 

14. Enter the file name and click the Save button .  
15. Click the File > Close menu item.  
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eXe Authoring 
eXe is a freely available open-source authoring application to assist teachers and academics in 
publishing web content without the need to become proficient in HTML or XML markup.  eXe 
allows users to: 
 
♦ Use instructional devices (or iDevices) to build course content 
♦ Format content  with a rich text editor 
♦ Embed multimedia assets 
♦ Package and export resources in IMS Content Package, SCORM 1.2, or IMS Common 

Cartridge formats or as simple self-contained web pages 
 
The following procedure shows you how to author an E-Learning course online using eXe: 
 
Procedure 

 

1.  Click the Free Text iDevice .  
2.  Click the Insert Table button .  
3.  Click the Insert button .  
4.  Type the text for the page in the text entry box.  
5.  Click the Image button  to insert an image.  
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6.  Click the Browse button .  
7.  Select the desired image file and click the Open button .  
8.  Click the Insert button .  
9.  Click the Done button to save the page  .  
10. Click the Edit button  to edit the page content.  
11. To add an audio narration, position the cursor in the text box and click the Insert Media button . 

12. Select the desired media format.  
13. Click the Browse button .  
14  Select the desired media file and click the Open button ..  
15. Click the Insert button .  
16. Click the Done button to save the page .  
17. To rename the page title, click the Rename button .  

 

18. Type the new page name and click the OK button .  
19. Click the Add Page button  to add the next page.  
20. Repeat the appropriate steps to add iDevices, course content, and media assets to the course.  
21. To add a knowledge check page, click the Multi-choice iDevice .  
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22. Type the question, hint, option/answer, and customized feedback in each of the text boxes.  
23. To add additional answer and distracters, click the Add another option button   
24. Click the Answer radio button  next to the correct option.  
25. Click the Done button to save the page .  
26. Click File > Save to save the course package.  
27. Click the OK button .  
28. Click the File > Export > SCORM 1.2 menu item to create an exportable package.  
29. Type the name the package file and click the Save button .  
30. Click the OK button .  
31. Click File > Quit to close eXe.  

 
WARNING: Do NOT use the Window close button to close eXe. The window will close, but the eXe 
session will continue running 

32. The packaged course  is ready to be loaded to your learning management system.  
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myUdutu Authoring 
myUdutu™ is a free web-based tool which allows users to create highly interactive SCORM-
compliant E-Learning courses quickly and easily.  myUdutu provides: 
 
♦ Collaborate from anywhere 
♦ Stencil-based authoring 
♦ WSIWYG (What You See Is What You Get) editing so users don’t need to know how to 

write code 
♦ Templates to build branching scenarios 
 

Note:  myUdutu is offered by Udutu Learning Systems Inc.  It is a trademarked system, 
and as such, is not considered an open-source application.  However, because of the 

full-featured functionality, ease-of-use, and no-fee nature of this tool, myUdutu is included in 
this workbook. 
 
The following procedure shows you how to author an E-Learning course online using myUdutu: 
 
Procedure 

 

1.  Type a course name in the Your course name field and click the Create New Course button 
.  
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2.  Click the SCORM 1.2 radio button selection .  
3.  Click the Save button .  
4.  Click the 1. Course Introduction course outline page item.  

 

5.  Roll your mouse cursor over the Media Location and click the Add button .  

 

6.  Type a title in the Title field.  

7.  Click the Browse… button .  

8.  Select the desired file and click the Open button . 

9.  Click the Save button .  
10. Roll your mouse cursor over text object and click the Add button .  
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11. Type a title in the Title field.  
12. Type the text for the page.  The rich text editor allows you to do basic text formatting.  
13. Click the Save button .  
14. Click the Add button to add a narration audio file .  
15. Type a title in the Title field. 
16. Click the Browse… button .  
17. Select audio file and click the Open button . 
18. Type a transcript for the narration file in the Narration Script text entry box.  
19. Click the Save button  in the Add Content Editor window.  

20. Click the Save button  in Edit Basic Screen window to save the page.  

 To view how the page will appear online in a course, click the Preview link .   

21. Click the Basic Screen link to add a new page . 
22. Repeat the appropriate steps to add content and media assets. 
23. Click the Assessment Screen link  to add a new assessment page.  
24. Type a title in the Title field. 

25. Click the Save button .  
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26. Type any instructions for the question in the Instructions text entry box.  
27. Type the question in the Question text entry box.  
28. Type the answers and distractions for the question in each of the Answer text boxes.  
29. Click the Correct checkbox  next to each correct answer.  
30. Type any desired customized feedback in the Feedback text entry boxes.  
31. Click the Save button  to save the page.  
32. To publish the course, click the Distribute tab . 

 
33. Click the Extract button . 

 
34. Click the "Click Here to get your course!" link.  
35. Click the Save File radio button .  
36. Click the OK button  to save the packaged ZIP file.  
37. Click File > Exit to close your Web browser.  
38. The course has been packaged and is ready to be loaded into your LMS system.  
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Resources 
You can use the following links to access, download, and experiment with these resources that 
will assist Instructional Designers in developing E-Learning assets: 
 

Application Site URL 
7-ZIP http://www.7-zip.org/ 

7-Zip is a file archiver with a high compression ratio.  Supports packing / unpacking 7z, ZIP, GZIP, BZIP2, 
and TAR formats. 

Audacity http://audacity.sourceforge.net/ 
Audacity is a free, easy-to-use audio editor and recorder.  You can use Audacity to record live audio and 
create/edit sound files (e.g., MP3, WAV). 

eXe http://exelearning.org/ 
eXe is an authoring application to assist teachers and academics in publishing Web content without the need 
for writing code. 

GNU Image Manipulation Program http://www.gimp.org/ 
The GNU Image Manipulation Program is a freely distributed piece of software for such tasks as photo 
retouching, image composition and image authoring. 

LimeSurvey http://www.limesurvey.org/ 
LimeSurvey basically contains everything you need for doing nearly every survey with grace. 

myUdutu* http://www.myudutu.com/ 
myUdutu is easy-to-use online learning authoring software that allows you to build a course very quickly, no 
matter where you are.  myUdutu’s WSIWYG online learning software makes it easy to produce media-rich, 
engaging online courseware without having to rely on programmers or multimedia experts. 

Paint.NET http://www.getpaint.net/ 
Paint.NET is free image and photo editing software for Windows computers, featuring an intuitive and 
innovative user interface with support for layers, unlimited undo, special effects, and a wide variety of useful 
and powerful tools. 

Reload Editor http://www.reload.ac.uk/ 
RELOAD Editor is part of a suite of software tools for authoring and delivery of standard-compliant learning 
objects, allowing users to author and transfer learning objects, in specification compliant format, between 
authoring and design tools, local and distributed digital repositories, and virtual learning environments.  The 
associated SCORM Player is a cross-platform desktop application that lets you "play" and test your SCORM 
1.2 package. 

SourceForge* http://sourceforge.net/ 
SourceForge is the global technology community’s hub for information exchange, open source software 
distribution and services, and goods for geeks. 

Wink http://www.debugmode.com/wink/ 
Wink is a Tutorial and Presentation creation software, primarily aimed at creating tutorials on how to use 
software (like a tutor for MS-Word/Excel etc)by capturing screenshots and adding explanations/instructions. 

* Web-based tool or service that is used online and is not downloaded 
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Where are You From?

Why participate in this session?

• Determine whether open-source 
applications are a viable fit for an 
organization

• Calculate the cost of ownership for open-
source applications

• Develop a SCORM-compliant eLearning 
module using free technology tools
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Questions to Consider
• What is open-source software? 
• Does IT fit?
• Would these apps work for me?
• How much do these apps cost?
• How do I show my message?

– Paint.NET
– GIMP

• How do I demonstrate steps?
– Wink

• How do I tell my message?
– Audacity

• How do I put it all together?
– eXe Learning
– MyUdutu

What are other resources?
• Primo PDF
• 7-ZIP
• OpenOffice
• GoogleDocs
• GoogleVideo/YouTube
• Picassa
• Zoho
• Skype
• Reload Editor
• LimeSurvey

• ATutor
• Moodle
• eFront
• FileZilla
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